Using Emulator Sessions

This chapter describes how to use the printing, editing, and data transfer functions in an emulator session. It also describes some of the choices in the emulator session Actions, Window, and Settings -> Appearance menus.

Accessibility

Z and I Emulator for Windows provides functionality with assistive technology such as screen readers. Following are some of the accessibility-related enhancements.

Sounds

Z and I Emulator for Windows supports the ShowSounds and SoundsSentry options available in the Windows Control Panel -> Accessibility Options -> Sound dialog. The ShowSounds option displays a string representing the event that generated a sound in the status bar.

To mute all of the sounds generated by Z and I Emulator for Windows, select the Mute option in the Settings -> Appearance -> Display Setup -> Sound panel.

Screen Reader Assist

Users can configure a toggle key to enable Z and I Emulator for Windows to replace blank and null characters in the input field with another character. This option enables screen readers to report the length of the field to visually impaired users. Data sent to and from the host is not changed--only the screen display and the screen reader's voicing of the display are affected. By default, this function is not enabled.

For 3270 and VT emulators, the default padding character is a blank. For 5250, the default replacement character is an underscore. You can choose another character if you prefer.

During the emulation session, you can turn the screen reader assist on or off, as needed. To map the screen reader toggle to a key, click Settings -> Keyboard. Click Customize to access the keyboard setup dialog. Refer to the online help for a complete list of available keyboard functions.

Expanded OIA

For an accessible version of the Operator Information Area (bottom line of the session), you can display the expanded OIA window. Click View -> Expanded OIA from the session menu bar. You can also select Show Expanded OIA from the session's system menu. You can change the number of lines displayed in the expanded OIA in the Settings -> Appearance -> Window Setup dialog.

To set focus to the expanded OIA so that a screen reader can read the values, you need to map a key to the function OIA: Toggle focus to/from Expanded OIA. This key enables you to toggle focus back and forth between the session window and the expanded OIA window. When you set focus to the expanded OIA window with a key, the focus in the expanded OIA is always set to the first line. When you return to the session window, the cursor should be where it was before you went into the expanded OIA window. Refer to the online help in the Settings -> Keyboard -> Customize dialog, for more information about custom key mapping.

Popup Keypad

Even though most users use the popup keypad with a mouse, it is possible to customize and use the poppads with the keyboard alone. To display (execute) a poppad without a mouse, you must map a few keys in the Settings -> Keyboard -> Customize dialog.

The Display Poppad function shows the last poppad and puts keyboard focus on it. The functions Display Poppad Pad 1, Display Poppad Pad 2, Display Poppad Pad 3, and Display Poppad Pad 4 display a specific poppad and put keyboard focus on that pad. You can execute the button with current focus by pressing the space bar or the Enter key.

If you are using a sticky poppad, the poppad window remains open until you close it. A regular poppad exits when you push one of the buttons. To get focus to a sticky pad without a mouse, you must map the Set Focus to Poppad function to a key--this sets focus to the sticky poppad from the session window. Because you must use the Ctrl-Tab key combination to get focus from the sticky poppad back to the session, mapping the Set Focus to Poppad function to the Ctrl-Tab key combination is not advisable.

Quick Connect

You can connect a Telnet (3270/5250/ASCII) session quickly using the Quick Connect bar by configuring only Host, Port and LU Name (3270)/Workstation Id (5250). The LU Name and Workstation ID are optional.

The Quick Connect bar is enabled only for Telnet sessions (both display and Printer). For non-Telnet Sessions, the Quick Connect bar does not appear.

While using the Quick Connect bar, the other session parameters are taken from the active session, if any. If no session is active, then all session parameters will be of default.

You can activate or deactivate the Quick Connect bar by clicking View -> Quick Connect Bar in the session window menu.

Power Management

Z and I Emulator for Windows complies with Microsoft Windows Power Management requirements for handling sleep events (stand by and hibernate). This support minimizes session interruptions due to network disconnections caused by sleep on Windows 7 and later versions.

Connected State

When Z and I Emulator for Windows is in the connected state and Windows 7 or later operating system indicates that the user is available for interaction, Z and I Emulator for Windows prompts the user to grant permission to sleep.

You can specify a setting in the Preferences Manager that allows the system to standby or hibernate without prompting. In default mode (unchecked), if there is at least one connected session, you will be prompted to allow the system to standby or hibernate. If there are no connected sessions, Z and I Emulator for Windows allows the system to standby or hibernate without prompting. See Standby/Hibernate.

Non-Connected State

When Z and I Emulator for Windows is not in the connected state, Windows 7 and later operating systems might automatically sleep, without prompting the user for permission.

Critical Sleep

When Windows 7 and later operating system's resumes after an emergency suspension, Z and I Emulator for Windows might display and log a warning message.

Refer to the Administrator's Guide and Reference for more information about Power Management.

Printer Session Association

When you configure a 3270 or 5250 display session, Z and I Emulator for Windows lets you specify an associated printer session.

Advantages of this association are as follows:

When configuring a session, if you want the server to associate a printer with the session, do the following:

  1. Click the Printer Association tab.
  2. Select Associated Printer Session.
  3. Enter the .WS file for the printer that is to be associated with the session. You can also click Browse to locate the file.

You can also set the following options:

Notes:
  1. Stopping a Telnet session automatically closes an associated printer session, if that option was selected when configuring the session.
  2. If a 5250 printer session is associated with multiple 5250 display sessions, then the printer session ends only when the last associated display session ends.
  3. For a 5250 session, if the host name in the selected printer session profile differs from the values in the display session profile, then the display session profile host name is used instead. The display session values are not saved to the printer session profile.

Print Session Setup (3270 and 5250)

The Print Session Setup dialog enables you to customize the display options for a 3270 or 5250 printer session. This dialog can be accessed by clicking Settings -> Appearance -> Print Session Setup. You can also add the Print Session Setup dialog to the session tool bar.

The following customization options are available.

Show Text Information
You can specify the title and other information to be shown in the printer session display window. If this option is not selected, no text information about the session is displayed.
Configuration Details

The following items can be included in the text information.

Connection Details
The following display options are based on the session status and the settings of the Session Parameters -> Advanced and Customize Communications dialog.
Connection Status If this item is selected, Connected is displayed if the session is in connected state. Disconnected is displayed if the session is not connected.
Host Name Host name or the IP address for the connection.
Host Type Host system type to which the session is connected.
Interface Interface type selected in the Customize Communication dialog.
Attachment Physical and logical connection selected for the session.
WS Profile If the session is started from a saved workstation (.WS) profile, the name of the profile is displayed. The field is blank if it is a newly configured session.
Host Codepage Code page selected in the host Session Parameters configuration panel.
Host Device Details

The following display options are based on the selected device and the settings of the Session Parameters - 5250 Host > Advanced dialog. These options are available for 5250 sessions only.

Device Status If this item is selected, Started is displayed if the device is in ready state. Stopped is displayed if the device is not in Ready state.
Workstation ID Device name for the session.
Message Queue/Library Message Queue and Message Library specified in the Session Parameters -> Advanced dialog
Host Font Host font selected in the Session Parameters -> Advanced dialog
HPT If this item is selected, TRUE is displayed if Host Print Transform is enabled. FALSE is displayed if HPT is not enabled.
HPT Printer Model If this item is selected, the Printer Model is displayed. If HPT is not enabled, Not configured is displayed.
HPT Drawer 1 If this item is selected, the HPT Drawer 1 paper size is displayed. If HPT is not enabled, Not configured is displayed.
HPT Drawer 2 If this item is selected, the HPT Drawer 2 paper size is displayed. If HPT is not enabled, Not configured is displayed.
Envelope Hopper If this item is selected, the Envelope Hopper is displayed. If HPT is not enabled, Not configured is displayed.
Customization Object/Library If this item is selected, the Customizing Object and Customizing Library are displayed. If HPT is not enabled, Not configured is displayed.
ASCII code page 899 If this item is selected, TRUE or FALSE is displayed, depending on whether ASCII Code Page 899 is enabled. If HPT is not enabled, Not configured is displayed.
Show Wallpaper
You can specify a bitmap file as a background in the session window. You can use the default graphic or another monochrome, 16-color, 256-color, or 24-bit file.
Print Status Dialog -> Show Dialog
You can have a printer status dialog displayed along with the session window. This option is available only for 5250 sessions.
Print Status Dialog -> Contain in Session Window
You can display a printer status dialog that is tied to the session window. When the session window is moved or minimized, the printer status dialog is moved with it. This option is available only for 5250 sessions.

Printing

You can use Z and I Emulator for Windows to print from display or printer sessions:

To print, the following methods apply:

For more information about printing, refer to Emulator User's Reference.

Print Screen Collection functions

Using the Collect Screen function, you can add a capture of all or part of the screen to a collection of captures.

To add the current screen (or part of the screen) to the collection, click File -> Print Screen Collection -> Collect Screen.

To print and purge all the collected screens, click File -> Print Screen Collection -> Print and Purge Collection.

To print and keep all the collected screens, click File -> Print Screen Collection -> Print and Keep Collection.

To preview the collected screen and select collected screens to be printed or purge, click File -> Print Screen Collection -> Prpcess Collection.

All the collected screens can be deleted without printing by clicking File -> Print Screen Collection -> Purge Collection. An individual screen or part of the collection cannot be deleted.

The File -> Print Screen Collection -> Print Collection on Exit option ensures that the collected screens are printed before you close or disconnect the session. This option is enabled by default. To end the session without printing the collected screen, clear the Print Collection on Exit option. All the collected screens are then deleted when you close or disconnect the session.

Note:
The Collect Screen feature works independently of the normal Print Screen function. You can still use Print Screen to print individual screens, while collecting multiple screens.

You can add the Collect Screen and Print Collection functions to the toolbar, a popup keypad, or a custom keyboard map. The settings in the Page Setup dialog are used (shared with the normal Print Screen function).

In PDT mode, there is an option available for printing more than one screen in a page. Refer to Administrator's Guide and Reference for more information.

Collecting Print Jobs (5250 Printer Session)

You can collect 5250 print jobs and print them as a single job or in a group. The collected print jobs are stored in a .SCS file.

You can set the following .WS profile keywords to specify the path and file name for the .SCS file.

[Printers]
SCSFile=<filename>.scs
SCSPath=<local path>

The functions associated with this feature are listed below. The functions can be mapped to the keyboard, popup keypad, mouse button, or toolbar button.

Refer to the online help for details about mapping the functions.

The CombineJobs profile keyword enables you to collect the jobs for printing, while maintaining them as individual jobs (instead of one job in the .SCS file). Specify the .WS keyword as follows:

[Printers]
CombineJobs=N

If you set CombineJobs to N, the Print Collection function sends the separate, collected jobs to the printer. While in Collect Mode, if the keyword is set to Y or is not specified, the print jobs are combined as a single job in the .SCS file.

Using the Windows Printer Driver

To set up your printer to use a Windows printer driver:

  1. Click File -> Printer Setup in the session window.

    The Printer Setup window lists the supported printers.

  2. Select the printer driver to be used from the Printer list box. DEFAULT will cause the use of the Windows default printer.
    Notes:
    1. The DEFAULT selection is shown when the .WS file specifies printer=DEFAULT in the [printers] stanza.
    2. When this selection is made, no message appears before the job is printed.
    3. When a printer has been selected for a session, the name of that printer is displayed in the status bar of the session window.
  3. If desired, click on the check box to Show this dialog before every print.
  4. Confirm that the Use PDT file check box is not selected and then select OK.

    Z and I Emulator for Windows will now use the printer driver you selected, and the Printer Setup window is closed.

Using Printer Definition Table (PDT) Files

Printer Definition Table files define the transfer of characters and control codes to a printer, and the printer output format. If a PDT file is used, the Windows printer driver is not used, and Z and I Emulator for Windows generates print output based on printer control information defined in the PDT file.

Refer to Administrator's Guide and Reference for more information about PDT files.

To use PDT files:

  1. Click File -> Printer Setup in the session window.

    The Printer Setup window appears.

  2. Select the port to be used from the Printer list box.

    Selected PDT files are available for the port selected here.

  3. Select Setup and then specify the paper size of the selected printer driver.
  4. Select the Use PDT file check box and then select Select PDT.

    The Select PDT file window appears.

  5. To use an existing PDT file, select a PDT file to be used and then select OK.

Using Host Print Transform (5250 only)

When configuring a 5250 printer session, the HPT mode may be selected. To use Host Print Transform (HPT), do the following:

  1. From the Session Parameters panel, click Advanced.
  2. Select HPT Yes. You can then enter the following parameters:

Image Print Transform

Z and I Emulator for Windows allows use of Image Print Transform in 5250 print sessions, when using Host Print Transform. Refer to the most recent IBM® iSeries, eServer i5, or System i5 printing reference for more information on this feature.

Page Setup

Z and I Emulator for Windows allows you to set Page Setup parameters, such as the maximum number of lines per page, the maximum number of columns, and fonts. You can also add a header or footer to a page.

For detailed Page Setup information and instructions, refer to Emulator User's Reference.

Scalable (Truetype) APL Font Support on Printers

Because special APL characters are not provided for printers, the APL fonts provided for displays are used when APL characters are printed. In some cases, APL characters are printed rather small. To print larger APL characters, you should install the Z and I Emulator for Windows AICAPL font, using the Windows Control Panel -> Font dialog.

ZipPrint (3270 Only)

Use ZipPrint to print PROFS™ notes, calendars, CMS files, XEDIT workspaces, and 3270 session screens.

Preparing to Use ZipPrint

Before you can use ZipPrint, DDE/EHLLAPI must be enabled for the sessions. To do this, click Settings -> API and refer to the online help for detailed instructions. DDE/EHLLAPI is enabled by default.

Note:
By default, PROFS-oriented functions of ZipPrint are U.S. English PROFS. You can customize ZipPrint for other languages. Start ZipPrint before you start any display sessions.

Starting ZipPrint

Start ZipPrint before you start any display sessions. The ZipPrint menu is added to the menu bar of the specified session window; then you can use it from the menu bar the same as with the other functions.

Start ZipPrint by selecting the ZipPrint icon in the Z and I Emulator for Windows program folder. This starts ZipPrint for Session A only.

You can also start ZipPrint by placing it as the first command in a Z and I Emulator for Windows batch file.

For more information about ZipPrint, including information about using ZipPrint for additional emulator sessions, search for ZipPrint in Help.

Using ZipPrint

Keep the following consideration in mind when using ZipPrint.

ZipPrint uses the Z and I Emulator for Windows File Transfer function to print VM/CMS notes and files. On slower communication lines such as SDLC, Async (IIN), or when using a large packet or block size, you might experience a file transfer timeout. If this happens, you should increase the timeout delay as follows:

  1. Click Settings -> Transfer in the session window.
  2. Increase the timeout value to 150 seconds or longer.

Editing

You can edit the contents of your session window using the Windows clipboard and the Edit menu.

Note:
When using copy/cut functions, Z and I Emulator for Windows takes the entire contents from the session window and places it on the clipboard. To copy or cut only marked sections from the session window, you need to update the Cut/Copy options. To update the Cut/Copy options, do the following:
  1. Click Settings -> Edit.
  2. From the Edit Options window, select the Cut/Copy tab.
  3. From the Cut/Copy page, select the Only if a trim-rectangle is marked check box.
  4. Close the Edit Options window.
Undo
Cancels the most recent Edit operation, except for Copy Link, and restores the contents of the session window and the clipboard accordingly.
Cut
Copies the marked area into the clipboard and removes it from the display session window.
Copy
Copies (or duplicates) the marked area into the clipboard without removing it from the display session window.
Copy Append
Copies the marked area into the clipboard without removing it from the display session window. If there is already data in the clipboard, Copy Append adds the new data to it.
Copy As Image
Copies the marked area as a bitmap into the clipboard. If no area is marked, Copy As Image captures the entire presentation space as bitmap.
Note:
Undo functionality is not supported for Copy As Image.
Paste
Overlays the current contents of the clipboard into the session window, starting at the current cursor position.
Paste Next
If not all data was pasted, Paste Next is enabled and the remaining clipboard data can be pasted.
Clear
Removes the marked area of the session window. The clipboard contents are not altered.
Copy Link
Supports the DDE Copy Link function. To start a link between Z and I Emulator for Windows and another application program, mark an area of the session window, select Copy Link, and then select Paste Link in the other application program.
Note:
The command you should use for Paste Link or Paste Special depends on the application program you are using.
Find
Find text in Presentation Space of a display session. The text found is highlighted on screen. The search can be case sensitive or insensitive.
Send to Scratch Pad
Sends the selected contents of the Presentation Space into the Scratch Pad of the corresponding session.
Unmark
Removes the clipping (or marking) rectangle. The session window and the clipboard contents are not altered.
Select All
Marks the entire session window.

Edit Options

Paste Options

You can control how text is pasted before and after protected fields, and how tabulated text appears after it is pasted. The following Paste functions are available.

Field Wrap
Check this box if you want pasted data that falls onto a protected field to move to the next unprotected field. If you do not check this box, any data that falls onto an unprotected field is lost.
Line Wrap
Check this box to allow pasting of copied text across lines.
Don't Split Words
Check this box to avoid words being split across fields and lines. The text being pasted into fields is split on word boundaries, which breaks the text and starts the new word in the next field. If one word is being pasted into a field, but the field is not long enough to hold the word, then as much of the word as possible is put into the field, and the rest of the word is carried on to the next field.
Note:
If the Field Wrap or Line Wrap option is not enabled, the word break option is not available.
Paste to marked area
Check this box to restrict pasting to a marked area, if it exists. If the marked area doesn't exist, pasting will take place at the current location.
Stop pasting when protected line encountered
Check this box to have the pasted text stop when it comes to a protected line on the emulator screen. If you do not check this box, the paste continues.
Tab Character Processing
Advance to next tab stop
You can choose to align tabulated text at specified tab stops. For example, if you choose Advance to next tab stop 4 column(s), your tabulated text is advanced to the column position that is the next multiple of 4.
Replace with n space(s)
You can choose to replace tab stops with a certain number of spaces. For example, if you choose replace with 3 spaces, each tab stop in your original text becomes 3 spaces.

The default setting is to replace each tab character with one space.

Paste data to fields
You can choose to have tabulated text placed in subsequent unprotected fields. With this option, when a tab character is encountered, the following text data will be pasted into the next unprotected field of the emulator session.
Note:
This option is available only for 5250 sessions.

Cut/Copy Options

You can control the size of the copy area and how +/- signs behave with signed numeric fields (5250 only).

Only if a trim rectangle is marked
Select this box if you want to copy only the trim rectangle that has been marked on the session screen. The default is to copy the entire screen if no rectangle is marked.
Autocopy
This option enables you to automatically copy the selected text to the clipboard. When an existing selected area is moved to another screen area, the text inside the new selected area is automatically copied to the clipboard.
Force Leading +/-
On a signed numeric field, the Force Leading +/- option will force the +/- sign to be at the beginning of the field rather than at the end.
Note:
This option is available only for 5250 sessions.

Trim Options

You can control the behavior of the trim rectangle.

Classic Box Style
This option allows you to draw a normal box like Trim Rectangle.
Trim Rectangle sizing handles
Check this box to add "handles" to the trim rectangle, allowing you to modify the size.
Trim Rectangle remains after edit function
This option keeps the trim rectangle active after completing the trim.
Expand Trim Rectangle during drag
This option causes the trim rectangle to step to character boundaries while it is being sized.
Use solid Trim Rectangle
This option changes the appearance of the trim rectangle. Instead of the standard outline boundary, the trim area appears as a solid box.
Windows Style
This option allows you to make uneven selection in the PS. When this option is selected, solid Trim rectangles without sizing handles are drawn by default.
Note:
Undo functionality under the Edit menu is disabled for this functionality.

Editing by Linking to Windows Application Programs

Linking to Windows application programs supporting Paste Link lets you paste session-window data to the windows of those application programs. You can run Copy Link when DDE/EHLLAPI is usable.

Confirming the DDE/EHLLAPI Settings

To check whether DDE/EHLLAPI is currently set to usable status, do the following:

  1. Click Settings -> API.
  2. Make sure the DDE/EHLLAPI check box is selected.

    If the box is checked, DDE/EHLLAPI is set to usable status. Continue to step 4.

  3. If the box is not checked:
    1. Click the DDE/EHLLAPI check box and then click OK.
    2. Stop and then start your session to enable the new settings.
  4. If DDE/EHLLAPI was already set to usable status, select OK.

Using Copy Link and Paste Link

  1. Mark the session window area for which Copy Link should be issued.
  2. Select Copy Link from the Edit menu.

    If the session window is already linked with an application program, Copy Link appears in gray and cannot be selected. In this case, force the application program to end the linkage, or stop the application program. Then you can select Copy Link.

  3. Start the Windows application program for the window to which an area should be copied.
  4. Specify the location for which Paste Link should be run.
  5. Issue Paste Link or Paste Special by using the menu for the application program.

    The contents of the marked area are pasted into the specified location in the window of the application program.

    Copy Link is now completed.

When the contents of the marked area in the session window are updated during linking, the contents of the area pasted to the window of the linked application program are also updated.

See the online help for more information about the Copy Link and Paste Link functions.

Copying Table Data to a Spreadsheet

You can use the Cut, Copy, Copy Link, or Copy Append choices in the Edit menu to copy data in the session window to the window of a Windows spreadsheet application program.

To use Copy, select the Paste or Paste Link choice in the application program window into which data is to be copied.

Data in the marked area can be copied in the following three data formats, depending on the format supported by the spreadsheet for the window to which data is to be copied:

Sylk format
Data format for general-purpose spreadsheets, such as Multiplan
BIFF format
Data format for Microsoft Excel
Wk3 format
Data format for Lotus® 1-2-3
Note:
Whether application programs, such as Excel or Lotus 1-2-3, also support these data formats in subsequent versions depends on individual application program specifications.

Individual items of data in tables of the session window are divided automatically such that they are suitable for spreadsheets, and they are copied into individual cells of tables in the application program.

Copying Marked Data without Dividing It into Cells

To paste data in the marked area per line, without dividing it into individual cells, add the following lines to the workstation profile:

[Edit]
Sylk=N       (If Sylk format data is not divided into cells)
Biff3=N      (If Biff3 format data is not divided into cells)
Wk3=N        (If Wk3 format data is not divided into cells)

Copying Lines Containing Only Operational Signs

If data in the marked area contains signs, such as +, -, =, or |, the signs are regarded as being ruled lines of the table. Once they are removed, only numeric data is copied.

Table 6. Table Data in Marked Area
1 2 3 4
1990 60 -63 71 +58
1991 +69 69 90 80
1992 71 +80 80 -30
Table 7. Data Copied to Spreadsheet
1 2 3 4
1990 60 -63 71 58
1991 69 69 90 80
1992 71 80 80 -30

To copy these signs without replacing them with null characters, add the following lines to the workstation profile:

[Edit]
MaskGridCharacter=N

Copying Data in Cells As Text Data

Data in the marked area is treated as numeric data by default. Therefore, currency symbols, such as $, and punctuation marks, such as commas, are removed before copying. To copy data containing such signs and marks as text data rather than numeric data, add the following lines to the workstation profile:

[Edit]
ConvertToNumeric=N

Data in the marked area containing signs and marks is then copied as text data. In addition, all numeric data that does not contain signs and marks is also copied as text data.

Transferring Files

Z and I Emulator for Windows enables the transfer of one or more files between a host system and workstation. You can define file transfer options in advance to help you transfer a variety of files quickly and easily.

Note:

PCT400 was withdrawn from marketing 3/98.

With Z and I Emulator for Windows, you can perform the following file transfer functions:

Send files to the host system
Send files using the Send File to Host from the Actions menu; or by clicking the Send button on the tool bar; or, when using 3270 sessions, the SEND command from the DOS prompt.

You can also send files by using an EHLLAPI or DDE application or a macro that invokes file transfer.

Receive files from the host system
Receive files using the Receive File from Host from the Actions menu; or by clicking the Receive button on the tool bar; or, when using 3270 sessions, the RECEIVE command from the DOS prompt.

You can also receive files by using an EHLLAPI or DDE application or a macro that invokes file transfer.

Data Transfer
For 5250 sessions, click Transfer from the Appearance menu; then select Data Transfer on the property page with the General tab. This causes the invoking of data transfer functionality when one of the above actions is taken. If Data Transfer is not selected, normal file transfer is invoked.
Create, test, replace, and delete templates
Create a template to have Z and I Emulator for Windows automatically generate a workstation or host file name and transfer type when you select a file to be sent or received.
Note:
It is not possible to define a file transfer template with the long file name naming convention.
Define transfer types
Define up to 16 transfer types for each host system. Text, binary, and append (except for CICS®) are initially set as transfer types.
Select, create, and customize translation tables
Select translation tables to define which translation table is used during file transfer.
Import or export files (PC/3270 only)
Import/Export is an office system communication program and an application program run on the IBM Customer Information Control System (CICS). The import/export function makes it possible to import or export Final Form Text (FFT), Revisable Form Text (RFT), and PC documents.

When you export a file from the host, your workstation receives the file you exported and an interchange document profile (IDP) file. Before you can import a file to your workstation, you need to create an IDP file with transmission information.

Create interactive document profile (IDP) files (PC/3270 only)
An IDP file contains document header information, has the same name as the file to be transferred, and has the extension .IDP.

To create an IDP file, select Transfer from the Appearance menu.

Note:
When you transfer a file on a Telnet5250 session, you cannot transfer a file that includes FFEF. The current version of the iSeries, eServer i5, or System i5 Telnet program misinterprets FFEF in the file as an end-of-record marker.

ASCII Host Data Transfer

When you are transferring files between two computers, specific protocols must be followed. Files can be transferred only when your PC uses the same protocol as the host. Z and I Emulator for Windows supports the XMODEM and YMODEM public domain protocols.

For XMODEM, Z and I Emulator for Windows uses the XMODEM and XMODEM1K protocols. XMODEM is a block-oriented, error checking protocol that is a single file, half duplex protocol. XMODEM1K is the same as XMODEM, except that it uses larger 1024 byte (1K) packets.

The YMODEM protocol is similar to the XMODEM1K protocol in that it transfers data in 1K packets, but it also allows multiple files to be sent in one transfer.

The YMODEMG protocol transfers multiple files like YMODEM, but performs no error detection or error correction. It can be much faster than YMODEM, but requires an error-free data connection.

With Z and I Emulator for Windows, you can perform the following data transfer functions to or from ASCII hosts:

Send any type of files to the host system
Send files using the Transfer menu using XMODEM, YMODEM, XMODEM1K, or YMODEMG.
Receive files from the host system
Receive files using the Transfer menu and XMODEM, YMODEM, XMODEM1K, or YMODEMG.
Create, test, replace, and delete templates
Create a template to have Z and I Emulator for Windows automatically generate a workstation or host file name and transfer type when you select a file to be sent or received.

Setting Up the Appearance of a Session Window

You can use the following functions to define the appearance of your session window. These options are in the Settings -> Appearance menu.

Display Setup
Customize a variety of characteristics, such as the cursor, pointer, rule line, and trimming styles, graphics, sound, and color palette, in the display session.
Color Mapping
Set the colors used in session windows.
Font
Choose the font to use for display session windows, the style, and whether it will be an automatic sizing font or a fixed size font. If you use a fixed size font, you can also choose its size. The set of fonts from which you can choose depends on the type of display you are using.
Note:
You cannot change the font size when the session window is maximized.
Window Setup
Change the appearance and title of the session window and change the session icon.

Sounds

Z and I Emulator for Windows enables customization of program sounds through the Windows Control Panel. You can configure specific program sounds using sound files included with the Z and I Emulator for Windows product.

A Mute function can be used to silence all program sounds. This option is available from the Settings -> Appearance -> Display Setup -> Sound dialog.

Tool Bar Setup

The tool bar displays under the menu bar in your session window to allow quick access to the Z and I Emulator for Windows functions, commands, and defined macros.

Use the tool bar pop-up menu to quickly and easily create, edit, and delete tool bar items, as well as to save and load customized tool bars. When you customize the tool bar, you can change the order of items, add and delete items, change the function, title, or graphic associated with any item, change the fonts, colors, and other tool bar visual style elements. The settings are stored in a .BAR file.

To customize your tool bar, select Tool Bar -> Tool Bar Style from the Settings menu, or display the Tool Bar pop-up menu by clicking on the right mouse button while pointing at any part of the tool bar.

For information about customizing the tool bar, refer to the online help.

If you want to hide the tool bar, see Showing or Hiding the Menu Bar, Status Bar, or Tool Bar.

Showing or Hiding the Menu Bar, Status Bar, or Tool Bar

You can show or hide the menu bar, status bar, or tool bar. If the menu bar is displayed, enable or disable status bar or tool bar from the session View menu. You can also do the following:

Window Setup

For some Windows operating systems, if you clear the Maximized Style -> With Title Bar option in the session Settings -> Appearance &rarrow; Windows Setup dialog, then the Minimize All Windows option on the Microsoft Windows taskbar may not have any effect. To minimize the window, press Alt-Space and click Minimize.

Setting Up and Using the Assist Functions

The auxiliary functions described in this chapter let you operate the system more efficiently. Keyboard/Macro/Script Function can be customized from the Actions menu. The other functions can be customized from the Edit menu.

Keyboard, Macro, and Script Functions

A Keyboard/Macro/Script Function command lets you run scripts, macros or Z and I Emulator for Windows-supplied key functions without using the keyboard. Run the scripts, macros or key functions from the current cursor position in the session window.

Scripting Functions

You can write, execute, record and terminate VBScripts in the emulator environment. These scripts have access to the HACL automation API. The programming environment includes methods, class descriptions and properties. VBScript is a subset of the Visual Basic programming language.

Macro Functions

A macro is a sequence of key or mouse actions and host commands that you can perform with a single action, such as a keystroke. Before you can use a macro function, you need to define it. For more information, see Macro/Script Setup and Use.

Key Functions

Z and I Emulator for Windows provides many key functions that can be assigned to the keys on the keyboard, the mouse buttons, or the buttons of the pop-up keypad. You can also use them to generate macros.

Hotspot Setup

A hotspot is an area of the session window on which you can double-click the left mouse button to perform a command or function. You do not need to use the keyboard. For example, you can double-click a function key number to perform the function.

Tip:
Select Show hotspots to get three-dimensional (3D) hotspots; these only require a single click, and they stand out on your screen.

You can define the following actions for a hotspot:

Using Hotspots

Note:
You must have a mouse to use hotspots

To use a hotspot:

  1. Move the mouse pointer to the hotspot displayed in the session window.
  2. Double-click the left button of the mouse, except for 3D hotspots, which only require a single click.

    Z and I Emulator for Windows determines whether you have specified a hotspot function that matches what appears at the position of the mouse pointer. If so, it processes the hotspot. When two or more hotspots are specified for a single character string, the first retrieved hotspot is processed.

    Hotspots are retrieved in the following order:

    1. Point-and-select (connect to Web site using URL)
    2. PFnn, FPnn, Fnn, nn
    3. Point-and-select (run the macro)
    4. Point-and-select (enter the selected string)
    5. Point-and-select (enter at the cursor position)

Keyboard Setup

You can use Keyboard Setup to modify the function defined for each key on the keyboard, except some reserved keys.

You can define the following functions for the keys.

Note:
By default, the Enter function is assigned to the Ctrl key. To change this assignment or, if the Enter key does not work properly, you need to customize your keyboard. For 3270 and 5250 sessions, you can use the keyboard map files provided with Z and I Emulator for Windows. Refer to Emulator User's Reference for more information about keyboard mapping and functions.

Keyboard File

When you specify a key, you can save the new keyboard layout in a file (.KMP). If you create two or more keyboard files, you can alternate between them as required.

To assign a function to a key on the keyboard:

  1. Select Keyboard from the Settings menu or click the map icon on the tool bar.
  2. When the Keyboard Setup window appears, select Customize.
  3. Assign the key functions, referring to the online help for detailed instructions.
  4. Save your changes and exit the Customize Keyboard window.
  5. Select OK after completing the setup.

You can reset either the entire keyboard or specific keys to defaults:

Note:
There are seven keys that you cannot redefine and they are gray or dimmed in Keyboard Setup; these keys are: Alt, AltGr, Print Screen, Scroll Lock, CapsLock, NumLock, and Shift.

Customizing the VT Emulator Keyboard

If you are using a VT emulator session, you can represent ASCII control characters in the character strings that you define for your customized keyboard.

Use the # character to represent the CTRL key, following it by any character from the following list (only upper-case alphabetics are allowed):

@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_

Use ## to represent an actual #. For example, 123##45 represents 123#45.

If you follow # with any other character than those shown, you will get an error message:

PCSKBD160 - Unrecognized key-action: "character string

For example, the error for the string "#a is

PCSKBD160 - Unrecognized key-action: "#a

The set of control characters is as follows:

Character pair Control Notes
#@ Control-@ NULL
#A Control-A
through
#Z Control-Z
#[ Control-[ ESC
#\ Control-\
#] Control-]
#^ Control-^
#_ Control-_

Because the *.KMP file can be edited, there is a run time check to ensure that the character string is correct. If "### is processed, then # will be displayed, followed by a beep to signify that the entire character string was not played. If "123#a456 is processed, then 123 will be displayed, followed by a beep.

Macro/Script Setup and Use

A macro is a sequence of key or mouse actions and host commands that you can perform with a single action, such as a keystroke. You can edit an existing macro or create a new macro by selecting Macro/Script from the Appearance menu.

A script is a VBScript program that is a subset of the Visual Basic programming language. For information on VBScript, see the online help pages.

Using a Macro or Script

You can use a macro or script in various ways. Table 8 lists examples of how you can set up and then use macros and scripts.

Table 8. Macro Use Examples and Settings
If you want to... Do this...
Automatically play a macro or script when your session starts. Set an Auto-Start Macro/Script.
Play a macro or script while attached to a host application. Start Playing Macro/Script.
Play a macro or script with the keyboard or macro function. Use the Keyboard/Macro/Script Function.
Click on a hotspot to play a macro or script. Set a Hotspot.
Assign a macro or script to a pop-up keypad button. Customize the Pop-Up Keypad file.
Press the mouse button to play a macro. Customize a Mouse file.
Press a key on the keyboard to play a macro or script. Customize a Keyboard file.

Creating a Macro

You can create a macro manually or by recording some of your interactions with the host system, such as your logon procedure.

To create a macro manually:

  1. Macro/Script from the Appearance menu.
  2. When the Macro/Script Setup window appears, select Customize.
  3. When the Customize Macro/Script window appears, select File, then New, then Macro, and edit the macro. You can type statements directly or select functions, characters, or even other macros, from the list of Key Actions in the Select a Key-Action subpanel.

    Refer to the online help for detailed information.

  4. Click File, then Save to save the macro file.
Notes:
  1. Macros that are converted to XML are intended for use in ZIEWeb (Z and I Emulator for Web) and will not function in Z and I Emulator for Windows emulation sessions. Use the HOD Macro Manager to import a converted Z and I Emulator for Windows macro into HOD. These converted macros will not appear in the list of available Z and I Emulator for Windows macros.

Macro Statements

You can use the following statements when you create a macro:

Key function
Use Z and I Emulator for Windows-supplied key functions
Macro
Define a macro within another macro but you cannot create a macro in a permanent loop where the first macro is repeatedly called at the end of the macros.
Character
Use any characters in the Character list in the Customized Macro window.
Character string
Use character strings you can type from the keyboard. You must use a double quotation mark (") at the beginning of the character string.
Wait condition
Specify wait conditions to stop the process until the specified time has elapsed or the status satisfying the specified condition occurs.
Tokens
You can use tokens, such as goto and run, to add logic.

Macro Loop Considerations

If you use a GOTO and a label in a macro to create a loop, you may experience unpredictable behavior if that loop executes a large number (more than 1000) of iterations.

Creating a Script

You can create a script manually or by recording some of your interactions with the host system, such as your logon procedure. Scripts, however, allow a higher level of programming control unavailable with macros.

To create a script:

  1. Macro/Script from the Appearance menu.
  2. When the Macro/Script Setup window appears, select Customize.
  3. When the Customize Macro/Script window appears, select File, then New, then Script, and edit the script. The Select a Key-Action subpanel, in gray, is not available for creating scripts.

    Refer to the online help for detailed information.

  4. Click File, then Save to save the script file.

Configuring a Macro or Script to Autostart

To configure a macro or script to autostart, do the following:

  1. Click Settings -> Macro/Script.

    The Macro/Script Setup window appears.

  2. Set a macro or script to autostart when your workstation starts.
  3. Refer to the online help for detailed instructions and then select OK after completing your setup.
Auto-start macro support

To specify which macro should be started automatically after start of a session, add the PCSWS option /M=<mymacro>, where <mymacro> is the name of the Z and I Emulator for Windows macro or script file. See the following example:

C:\ZIEWin\PCSWS.EXE C:\AppData\LAN1.WS /M=mymacro 

If the specified macro or script does not exist, the following error message will be returned:

PCSKBD400-
The file: <macro name> is not a Z and I Emulator for Windows macro/script-file

Configuring a Java Applet to Autostart

To run a Java applet automatically, you can add the function Run Applet to a macro. You can add this function to an autostart macro, so that an applet can be run at session startup.

  1. Click Settings -> Macro/Script.

    The Macro/Script Setup window appears.

  2. Select Run Applet from the Function drop-down list and type the name of the class.

Refer to the online help for syntax and detailed instructions.

Note: The applet class specified must exist in the same directory path as the .WS file in which the macro is included.

Recording Macros or Scripts

To start macro or script recording, use the following procedure:

  1. Click Start Recording Macro from the Actions menu.
  2. Type the macro or VBScript name.
  3. Select the record format.

    If you are recording a macro format file for Express Logon, select the Enable check box and enter the Express Logon Feature (ELF) Application ID.

  4. Configure the other options and click OK.
Note:
When recording a macro, the processing of a nondisplayable field is controlled by the setting of the parameter HideNonDisplayDataOnRecord=Y in the [Keyboard] stanza of the .WS file. The hidden fields are ignored during the recording session.

To cancel macro or script recording, click Actions -> Cancel Recording Macro. The recording operation is canceled, and the macro or script is not saved.

To pause macro or script recording, click Actions -> Pause Recording Macro. The recording operation stops. To restart recording, click Resume Recording Macro.

To end macro or script recording, click Actions -> Stop Recording Macro. Recording ends and the macro is saved in the specified file.

Playing Macros and Scripts

To play a macro or script, click Actions -> Start Playing Macro/Script, select the macro or script, and click OK. The selected macro starts to play.

To stop playing a macro or script , click Actions -> Quit Playing Macro/Script. The macro or script stops playing.

Note:
Z and I Emulator for Windows macro files more than 32KB in size cannot be played in the Z and I Emulator for Windows emulator session. If you want to play a macro file that is greater than 32KB, you will have to break the macro into multiple files.
Note:
When playing a macro, the processing of a non-displayable field is controlled by the setting of the parameter HideNonDisplayDataOnRecord=Y in the [Keyboard] stanza of the .WS file; setting this causes a pop-up window to display, requiring your input. When this appears, type in the requested information and press Enter to continue.

ThisMacroName support

The ThisMacroName property is used to enable a running script to obtain the name of the macro file that is running. This is useful when writing a script that will be using the name of the macro file.

See the following example of ThisMacroName:

[ZIEWin SCRIPT HEADER]
LANGUAGE=VBSCRIPT
DESCRIPTION=Example of usage of property ThisMacroName
[ZIEWin SCRIPT SOURCE]
OPTION EXPLICIT
Dim sName, sHandle

REM App Main
Main

sub Main()
	'Initialize the session
	autECLConnMgr.autECLConnList.Refresh 
	sName = autECLConnMgr.autECLConnList(1).Name
	sHandle = autECLConnMgr.autECLConnList(1).Handle

	'Connect to the current session
	autECLSession.SetConnectionByName(ThisSessionName)
	sName = autECLSession.Name
	sHandle = autECLSession.Handle

	MsgBox("The current session name :")
	MsgBox(ThisSessionName)
	MsgBox("The macro name is :")
	'Should pop up correct macro file name in the message box
	MsgBox(ThisMacroName)
end sub

Express Logon Feature

The Express Logon Feature (ELF) allows a Z and I Emulator for Windows TN3270E user to logon to a host application without sending the user ID and password. This function is designed to be implemented only in certain circumstances by administrators of Z and I Emulator for Windows. Refer to Administrator's Guide and Reference for detailed information on implementation.

Recording an Express Logon Macro

To record an ELF macro, do the following:

  1. Select the Macro file format of recording.
  2. Check the Express Logon for Macro Enable box.
  3. Enter the Application ID for Express Logon.
  4. Follow this sequence when the host prompts you to type the user ID:
    1. Type the user ID.
    2. Type the password into the non-display password field.
    3. Only after typing the password should you type any additional data needed for logon.

    As the keystrokes that were recorded during the logon are saved in the ELF macro file, Z and I Emulator for Windows will attempt to identify and replace the user ID and password that you enter with special placeholder strings, )USR.ID( and )PSS.WD(. This automatic recognition requires that the password be typed into the first non-display input field. The user ID is assumed to have been entered just prior to the password.

    If you make an error when typing any logon data, you must record the macro again.

During later playback of the macro, the ELF Application ID (stored in the macro) and the secured connection will be used to repeat the logon without the need for user ID and password.

You can also manually configure a macro for ELF. Refer to Administrator's Guide and Reference for more information.

Verifying an ELF Macro

You can visually inspect the macro recording of a host application logon to verify that the user ID and password have been replaced by Express Logon Feature (ELF) tags. The procedure is as follows:

  1. Open the macro file containing the recorded keystrokes by clicking Settings -> Macro/Script.
  2. Select the macro file you just recorded and click Customize.
  3. Verify that the user ID has been replaced with two tags: the ELF Application ID and the ELF user ID placeholder. The Application ID tag consists of three words, each separated by a blank character: elf, applid, and the identifier of the host application that will be logged onto. The user ID placeholder is )USR.ID(

    For example, "myUserID should have been replaced with ")USR.ID(.

  4. Verify that the Password has been replaced with the ELF Password placeholder tag )PSS.WD(.

    For example, "myPassword should have been replaced with ")PSS.WD(.

Mouse Setup

The Mouse Setup command lets you allocate functions to the right and left buttons of the mouse; this enables you to perform the following actions without having to use the keyboard:

Mouse File

You can save the functions defined for the mouse buttons in a mouse file (*.MMP). You can create two or more mouse files and switch between them as required.

To set up the mouseand assign functions to the mouse buttons:

  1. Select Mouse from the Settings menu.

    The current settings appear in the Mouse Setup window.

  2. Set up the required items, referring to the online help for detailed instructions.

    If you want to create or edit a mouse file:

    1. Select Customize.
    2. When the Customize Mouse window appears, allocate functions to the right and left buttons of the mouse. These appear in Current Action for Mouse Button.
    3. Select the required functions from List of Key Actions.
    4. Save your changes and then select OK.
  3. Select OK.

    The mouse setup is complete.

Pop-Up Keypad Setup

The pop-up keypad is a small window in which some buttons are arranged. To display the pop-up keypad, put the pointer anywhere in the session window and press the right mouse button.

You can allocate the following functions to these buttons:

To perform these functions, you only need to click a button on the pop-up keypad with the left mouse button.

To view the description of a short-name key function or macro, click the right mouse button while pointing at one of the function or macro names.

Pop-Up Keypad File

You can specify the number of buttons displayed in the pop-up keypad, the functions allocated to those buttons, and colors of the buttons. You can save the specified pop-up keypad contents in a pop-up keypad file (also referred to as a poppad file).

A pop-up keypad file (*.PMP) contains the information for the number of buttons displayed in the pop-up keypad, the functions allocated to those buttons,and color information. You can define which pop-up keypad file is allocated to the pop-up keypad.

Using the Pop-Up Keypad

To use a pop-up keypad:

  1. With the mouse pointer anywhere in the session window, click the right mouse button.
  2. Select Pad 1, Pad 2, Pad 3, or Pad 4.
  3. Click the required button in the pop-up keypad.

To set up the pop-up keypad:

  1. Select Popup Keypad from the Settings menu.
  2. When the Popup Keypad Setup window appears, set the required items, referring to the online help for detailed instructions.

    If you want to edit the pop-up keypad file, select Customize and then make your changes.

  3. Select OK. The pop-up keypad you selected is ready for use.

Tab Setup (VT only)

Tab Setup allows you to define tab stops for your VT sessions.

Web Browser Setup

Web Browser Setup allows you to define a preferred web browser and to use it rather than the one that comes with your operating system.

Managing Emulator Sessions

Z and I Emulator for Windows provides the following functions, in addition to those provided by Windows, for those who work with several open session windows simultaneously. These functions allow you to manage your session windows easily and quickly. The Window menu has the following selections:

Jump
Use Jump to switch between the currently opened session windows.

You cannot use Jump to switch to a session window that is currently hidden. Instead, select Show Session from the Window menu to display the session window on the screen. Then, select Jump.

Hide Session
Use Hide Session to stop displaying a visible session window.

You cannot hide all sessions. At least one session is always shown.

Show Session
Use Show Session to display a session window that was previously hidden with Hide Session.

Use the View menu to display a previously-saved arrangement of windows, or to save an arrangement of windows.

Z and I Emulator for Windows can save and restore the following information relating to the session window view:

You can save view information for up to eight windows.

Getting Help

For more information about managing session windows, refer to the online help:

  1. Select Procedures from the Help menu.
  2. When the help window appears, scroll down to Managing Workstation Windows.

    Select choices from that list for detailed information.

Online Emulator Session

Emulator sessions started from Session Manager online are displayed with "Online" Tag at end of Session Titles. Dialogs where create/modify or delete opertations for the .ws (Workstation profile),.bch - (Multiple Sessions or Batch),.pmp (Popup-Keypad Configuration).kmp (Keyboard Configuration).bar ( Toolbar Setup), .mmp (Mouse Setup) .xlt (Translation Table) are always online

Detect and Repair

You can use the Help -> Detect and Repair function to check the Z and I Emulator for Windows product integrity. The Detect and Repair operation performs a check on the installed Z and I Emulator for Windows files to determine whether the installation has been damaged. A subsequent repair is performed, if necessary.

Note: You should stop all active sessions before starting the Detect and Repair function.

Check Restore my shortcuts if you want your original shortcuts restored. If you have modified your shortcuts since the original Z and I Emulator for Windows installation, you might want to keep your shortcuts intact--in that case, do not choose this option.

In order to use the Detect and Repair function, you must be authorized in the System Policy. You might be prompted to provide the original Z and I Emulator for Windows installation source.

Z and I Emulator for Windows Detect and Repair can be invoked from the Session Manager or from an emulator session window. Windows Installer repair of the Z and I Emulator for Windows product is invoked from the Windows Add/Remove Programs function. Note the following differences in the operations.

Z and I Emulator for Windows Detect and Repair performs the following operations:

Alternatively, Windows Installer performs the following operations: